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NETSCAPE® SDK LICENSE AGREEMENT 

 
BY DOWNLOADING OR USING THE NETSCAPE SOFTWARE DEVELOPERS’ KIT 
(THE “SDK”), YOU ARE CONSENTING ON BEHALF OF YOURSELF AND THE 
ENTITY YOU REPRESENT TO BE BOUND BY THIS LICENSE AGREEMENT.  DO 
NOT USE THE SDK IF YOU DO NOT AGREE TO THE FOLLOWING LICENSE 
TERMS (“LICENSE AGREEMENT”).  
 
1. LICENSE GRANT. Netscape Communications Corporation, a subsidiary of America 

Online, Inc., (“Netscape”)  grants you a free-of-charge, personal, non-exclusive, and 
non-transferable license to use the SDK to develop themes that are compatible with 
the Nestscape Internet Browswer (“Themes”) and to compile the sample code 
included in the SDK (the “Sample Code”) into such Themes, subject to your 
compliance with the following terms. You may only distribute the Sample Code as 
part of a Theme that you may only distribute such Themes through channels 
authorized by Netscape and only pursuant to an end user license agreement 
containing terms no less restrictive than the end user license agreement for the 
Netscape Internet browser. Netscape is under no obligation to provide you with any 
other hard-copy documentation, technical support, telephone assistance, or 
enhancements or updates to the SDK. Netscape reserves the right to make changes 
to the Netscape browser that may have the unintended result of rendering any 
Theme inoperable with the updated Netscape Internet browser. 

 
2. RESTRICTIONS. Except as otherwise expressly permitted in this License 

Agreement or in writing by Netscape, you may not: (i) modify or create any derivative 
works of the SDK; (ii) decompile, disassemble, reverse engineer, or otherwise 
attempt to derive the source code for the SDK (except to the extent applicable laws 
specifically prohibit such restriction); (iii) redistribute, encumber, sell, rent, lease, 
sublicense, or otherwise transfer rights to the SDK; (iv) remove or alter any 
trademark, logo, copyright or other proprietary notices, legends, symbols or labels in 
the SDK; (v) redistribute the SDK; (vi) redistribute the Sample Code except as 
compiled into your Theme; (vii) upload or distribute any Theme that violates any law 
or the rights of others, including, the intellectual property rights of others; (viii) 
incorporate Sample Code into applications that are not compatible with the Netscape 
Internet browser; (ix) make any changes to the files in the Systems folder; (x) upload 
or distribute any Theme that would be unlawful, abusive, defamatory, insasive of 
privacy or publicty rights, vulgar, obscene, profane, indecent or otherwise 
objectionable; or (xi) use the SDK to develop a Theme that causes damage to or 
interfere with the proper functioning of the Netscape Internet browser or a user’s 
computer or computer files or that disable copyright protection measures 
(“Unauthorized Applications”). 

 
3. BLOCKING UNAUTHORIZED APPLICATIONS. Netscape shall have the right to 

block any and all Unauthorized Applications.  
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4. YOU REPRESENTATIONS. You represents and warrants that you have the legal 
capacity to enter into this License Agreement, that you will use the SDK only for 
lawful purposes and in accordance with this License Agreement, and that you will 
not use the SDK to violate any law, regulation or ordinance or any right of Netscape 
or any third party, including without limitation, any right of privacy, publicity, 
copyright, trademark, or patent. 

 
5. MODIFICATIONS TO SDK. Should you make any modifications to the SDK that you 

believe would benefit other users, you may submit the modified version of the SDK 
to Netscape, together with an explanation of the changes made, for Netscape’s 
review. Netscape shall own such modified versions of the SDK and shall have the 
right to distribute the modified version. 

 
6. CREDIT. You shall include in an appropriate location in your Theme a Netscape 

credit substantially similar to: “This application developed using the Netscape SDK” 
and a link to www.netscape.com, as well as information regarding the build number 
of the supported Netscape Internet browser. 

 
7. PATENT GRANT BACK. You agree that you will not assert any patent rights that 

you own or controls against AOL or Netscape regarding the Netscape Internet 
browser or the SDK. 

 
8. TERMINATION. This License Agreement and your right to use the SDK shall 

terminate immediately and without notice should you breach this License 
Agreement. You may also terminate this License Agreement by simply discontinuing 
use of the SDK. In the event of any termination of this License Agreement, the 
restrictions on use set forth in Paragraph 2 (“Restrictions”) shall survive such 
termination and you agree to continue to be bound by those terms. Upon 
termination, you shall destroy all copies of the SDK.  

 
9. PROPRIETARY RIGHTS. Title, ownership rights, and intellectual property rights in 

the SDK and the Netscape Internet browser shall remain in Netscape and/or its 
suppliers. You acknowledge such ownership and intellectual property rights and you 
will not take any action to jeopardize, limit or interfere in any manner with Netscape's 
or its suppliers' ownership of or rights with respect to the SDK or the Netscape 
Internet browser. The SDK and the Netscape Internet browser are protected by 
copyright and other intellectual property laws and by international treaties. All 
trademarks used in connection with the SDK are owned by Netscape, its affiliates or 
its suppliers, and no license to use any such trademarks is provided hereunder.  

 
10. INJUNCTIVE RELIEF. You acknowledges and agrees that, notwithstanding any 

other provisions of this License Agreement, your breach or threatened breach of this 
License Agreement shall cause Netscape irreparable damage for which recovery of 
money damages would be inadequate and that Netscape therefore may seek and 
obtain timely injunctive relief to protect its rights under this License Agreement in 
addition to any and all other remedies available at law or in equity. 
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11. INDEMNIFICATION. You agree to indemnify, hold harmless, and at Netscape’s 

request, defend Netscape and its affiliates from any and all costs, damages and 
reasonable attorneys' fees resulting from any claim that your Theme has injured or 
otherwise violated any right of any third party or violates any law. 

 
12. DISCLAIMER OF WARRANTY. THE SDK IS PROVIDED FREE OF CHARGE AND 

ON AN "AS IS" BASIS, WITHOUT WARRANTIES OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING WITHOUT LIMITATION THE WARRANTIES THAT THE 
SDK IS FREE OF DEFECTS, VIRUS FREE, ABLE TO OPERATE ON AN 
UNINTERRUPTED BASIS, MERCHANTABLE, FIT FOR A PARTICULAR 
PURPOSE, ACCURATE OR NON-INFRINGING, UNLESS SUCH WARRANTIES 
ARE LEGALLY INCAPABLE OF EXCLUSION. NETSCAPE AND ITS SUPPLIERS 
HAVE NO LIABILITY WITH RESPECT TO USE OF THE SDK OR YOU 
APPLICATIONS. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE 
OF THE SDK IS BORNE BY YOU. THIS DISCLAIMER OF WARRANTY 
CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE AGREEMENT. NO USE 
OF THE SDK IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS 
DISCLAIMER. 

 
13. LIMITATION OF LIABILITY. TO THE MAXIMUM EXTENT PERMITTED BY 

APPLICABLE LAW, IN NO EVENT WILL NETSCAPE COMMUNICATIONS 
CORPORATION, AMERICA ONLINE, INC. OR THEIR RESPECTIVE PARENTS, 
AFFILIATES, DIRECTORS, EMPLOYEES, DISTRIBUTORS, SUPPLIERS, 
AGENTS OR RESELLERS (COLLECTIVELY, THE “NETSCAPE GROUP”) BE 
LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, CONSEQUENTIAL, OR 
EXEMPLARY DAMAGES ARISING OUT OF OR IN ANY WAY RELATING TO THIS 
LICENSE AGREEMENT, INCLUDING, BUT NOT LIMITED TO LOST PROFITS, 
LOST DATA, LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE 
OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR 
LOSSES, EVEN IF SUCH PARTY HAS BEEN ADVISED OF THE POSSIBILITY 
THEREOF, AND REGARDLESS OF THE LEGAL OR EQUITABLE THEORY 
(CONTRACT, TORT OR OTHERWISE) UPON WHICH THE CLAIM IS BASED. IN 
ANY CASE, THE NETSCAPE GROUP'S ENTIRE COLLECTIVE LIABILITY UNDER 
ANY PROVISION OF THIS LICENSE AGREEMENT SHALL NOT EXCEED IN THE 
AGGREGATE THE SUM OF THE FEES YOU PAID FOR THIS LICENSE (IF ANY) 
AND REPLACEMENT OF DEFECTIVE MEDIA OR PROVISION OF A 
REASONABLY SIMILAR SDK, AS DETERMINED AT NETSCAPE'S SOLE 
DISCRETION, WITH THE EXCEPTION OF DEATH OR PERSONAL INJURY 
CAUSED BY THE NEGLIGENCE OF NETSCAPE TO THE EXTENT APPLICABLE 
LAW PROHIBITS THE LIMITATION OF DAMAGES IN SUCH CASES. SOME 
JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF 
INCIDENTAL, CONSEQUENTIAL OR SPECIAL DAMAGES, SO THIS EXCLUSION 
AND LIMITATION MAY NOT BE APPLICABLE. NETSCAPE IS NOT 
RESPONSIBLE FOR ANY LIABILITY ARISING OUT OF USE OF A YOU 
APPLICATION. 
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14. EXPORT CONTROL. You agree to comply with all export and import laws and 

restrictions and regulations of any United States or foreign agency or authority, and 
not to export or re-export the SDK or any direct product thereof in violation of any 
such restrictions, laws or regulations, or without all necessary authorizations. For 
example, You shall not export or re-export any commodities, software, or technical 
data received from Netscape, or any direct product of such commodities, software or 
technical data, to any proscribed country, party, or entity listed in the applicable 
laws, regulations, and rules of the U.S. Government unless properly authorized. As 
applicable, each party shall obtain and bear all expenses relating to any necessary 
licenses and/or exemptions with respect to its own export of the SDK from the U.S. 

 
15. U.S. GOVERNMENT END USERS. The SDK is a "commercial item," as that term is 

defined in 48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer 
software" and "commercial computer software documentation," as such terms are 
used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with48 C.F.R. 12.212 and 48 
C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users 
acquire the SDK with only those rights set forth herein. 

 
16. MISCELLANEOUS. (a) Except to the extent applicable law, if any, provides 

otherwise, this License Agreement shall be governed by the laws of the 
Commonwealth of Virginia, U.S.A., excluding its conflict of law provisions. (b) The 
parties expressly agree that jurisdiction for any claim or dispute relating to or arising 
out of this License Agreement resides in the courts of the Commonwealth of Virginia 
and each party further agrees and expressly consents to the exercise of personal 
jurisdiction in the courts of Virginia in connection with any such dispute. (c) If any 
dispute arises under this License Agreement, the prevailing party shall be 
reimbursed by the other party for any and all legal fees and costs associated 
therewith. (d) This License Agreement shall not be governed by the United Nations 
Convention on Contracts for the International Sale of Goods. (e) If any part of this 
License Agreement is held invalid or unenforceable, that part shall be construed to 
reflect the parties’ original intent, and the remaining portions shall remain in full force 
and effect, or Netscape may at its option instead terminate this License Agreement. 
(e) A waiver by either party of any term or condition of this License Agreement or 
any breach thereof, in any one instance, shall not waive such term or condition or 
any subsequent breach thereof. (f) You may not assign or otherwise transfer by 
operation of law or otherwise this License Agreement or any rights or obligations 
herein. (g) This License Agreement shall be binding upon and shall inure to the 
benefit of the parties, their successors and permitted assigns. (h) Neither party shall 
be in default or be liable for any delay, failure in performance (excepting the 
obligation to pay) or interruption of service resulting directly or indirectly from any 
cause beyond its reasonable control.  
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Netscape Theme Park Skin Guidelines 
Do NOT submit skins that you have not made yourself. 

You may not use Netscape Theme Park Skins to distribute or facilitate distribution of any content -- 
including text, communications, software, images, sounds, data, or other information -- that:  

Language: 
• contains vulgarities directed toward another individual or group. 
•  intends or advocates to victimize, harass, defame, degrade or intimidate an individual or group of 
individuals on the basis of age, disability, ethnicity, gender, race, religion or sexual orientation. Hate 
speech is unacceptable.                                                                                                                                                           
• contains sexual language that is violent or threatening.                                                                       

Graphics: 
• contains images in any format of sexual acts.   

Minors: 
• attempts to exploit a minor (under 18 years old).  
• solicits personal information from a minor (under 18 years old). Personal information includes full name, 
home address, home telephone number, or other identifying "offline" information.                                                      
• solicits for exchange, sale or purchase of sexually explicit images, and/or material harmful to minors. 

Advertising: 
• advertises for any product and/or service. Advertising is prohibited anywhere on Netscape.                                                                                                              

Illegal Activity: 
• is illegal or incites illegal activity including attempts to commit fraud, physical and/or death threats, or 
providing instruction on how to conduct or participate in illegal activity.  

Copyright and Trademark Infringements: 
• infringes on any patent, trademark, trade secret, copyright, right of publicity, or other proprietary right of 
any party.  

Network Abuse 
• uses our network in manner that is destructive (viruses), compromises the integrity of our consumer 
audiences (Trojans, password/billing solicitation), or distributes CD-Keys, serial number, etc.  

Violations of these guidelines may result in actions ranging from a warning, to suspension of access to a 
feature, to appropriate legal action.    

Netscape reserves the right to make changes to these guidelines at anytime and you agree to be bound 
by any such changed guidelines. Please check these guidelines periodically for any changes.  

For additional information, please refer to the Netscape Terms of Service. 

For more information about Netscape 8 themes or the Netscape Themepark, please contact:  
Patrick Murphy, Senior Program Manager, Netscape 614.538.3361 
patrickmurphy77@aol.com 
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Introduction 
This Software Development Kit (SDK) is for Visual Designers and Developers 
using Adobe Photoshop together with its integrated ImageReady tools and 
palettes for advanced Web processing and creation. The kit gives you everything 
you need to build a theme that takes advantage of the Netscape 8.0 visual 
interface: 

• Versatile design environment. This kit is designed to let you 
experiment with different creative concepts and ideas prior to 
implementing them in the actual build of your finished theme. 

• Start-to-finish framework. The tools within this tutorial are organized in 
a start-to-finish framework to help you build your new theme. Follow the 
steps in this document to ensure you achieve a successful theme. 

• Optimize and build. Use these tools provided in the SDK to help you 
successfully optimize graphics and build your new theme. 

• Directory file and css code support. Other tools are included in this 
SDK to help you work within the Directory File and the .css code in the 
directory file. We will go through those specific areas as needed in the 
step-by-step part of this tutorial. 

• Be creative and have fun. Begin by creating your own theme using tools 
provided here; use your imagination with your own theme graphics and 
color schemes. Experiment with different ideas. 

 

Though not supported in this tutorial, you can also use other graphic applications 
of your choice. If so, use processes that are as similar as possible to the steps 
outlined in this SDK in order to achieve the same results.  

 

NOTE: Netscape 8.0 is developed specifically for use on a PC.  
To ensure accuracy, you must test your new theme on a PC platform. 
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Step One: Download the Theme SDK 
1. If you have not already done so, download the Theme SDK file from here 

[http://browser.netscape.com/ns8/community/devtheme.jsp], and save to 
your computer. 

2. Navigate to the folder where you downloaded the Theme SDK zip file and 
locate the file NS_THEMESDK.zip. 

3. Double click on this file to launch your default compressed file extracting 
utility (i.e. Winzip or Stuffit Expander). 

4. Extract the contents of this zip file to \NS_ThemeSDK. 

 

Step Two: Extract the contents of the NS_fusion.jar 
1. Create a new folder in your NS_ThemeSDK folder (that you just extracted the 

SDK contents to in Step One) called MyTheme. 

2. Navigate to the NS_FusionTheme directory within the SDK directory you 
created in Step One (1) to locate the Fusion Jar file (called NS_Fusion.jar)  

3. Rename the NS_Fusion.jar file to MyTheme.zip file. 

4. Using Winzip or Stuffit Expander, extract the contents of the Fusion Jar to the 
\NS_ThemeSDK\MyTheme folder. 
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Step Three: Change the Name of the Theme 
1. Open the MyTheme folder, and open the install.rdf file using a text editor (i.e. 

Notepad). 

HINT:  Right click the install.rdf file, select Open With… then pick your text editor 
from the list. 

2. Scroll through the file to line 20: <!--Front End MetaData. -- > .  

• Below this line are four tagged portions of text you can change to 
label your theme: name, description, creator, and contributor. 

3. On line 21, replace ‘My Theme’ with the name of your theme. Make sure to 
leave the <em:name> and </ em:name> tags intact. 

Example 1: install.rdf to change the name of the Theme. 

 

 

4. On line 22, replace ‘My Theme Description’ with the description of your own 
theme. 

5. On line 23, replace ‘Netscape’ with the theme’s creator.  

6. On line 24, overwrite the ‘Netscape contributors’ text with your theme 
contributors. 

7. Save your changes to the install.rdf file, click OK to overwrite if you are 
prompted.  

8. On line 14 replace the current GUID# with a new GUID# (I.D.#) i.e. 
{3db10fab-e461-4c80-8b97-957ad5f8ea47}  

NOTE:  The GUID number must always be a unique number and have the same 
amount of characters as the above example. When replacing the GUID 
number you are only able to use characters 0 – 9 and A-F. A helpful tool to 
created GUID numbers can be found on the web. Just use a search engine 
and search for GUID generators. 

9. On line 27 replace ‘Fusion/1.0’ with your theme name (I.E. ‘MyTheme’). 

10. Open the contents.rdf file which is in the same directory of the install.rdf.    
 Replace any occurances of Fusion/1.0 with your theme name (I.E.   
 ‘MyTheme’) 
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Step Four: Use the NS_SDK_Fusion_Template.psd  
The NS_SDK_Fusion_Template.psd is a fully-layered representation of the 
Netscape 8.0 browser. Use it as a tool to help you visualize your theme. It is 
designed to allow you freedom to use your own creativity and experiment before 
you complete the final build of your theme (in “Step Five: Transferring your new 
theme graphic components” on page 14 of this document). 

NOTE: You must complete Step Four first, prior to building your theme in Step Five.  

To use the file: 

1. Launch Photoshop, and open the file 
\MyTheme\SDK_Photoshop\NS_SDK_Fusion_Template.psd.  

Example 2: \MyTheme\SDK_Photoshop\NS_SDK_Fusion_Template. 

 

 

2. Save a copy of the file with your custom theme name, i.e. 
\MyTheme\SDK_Photoshop\SDK_MyTheme_Template.psd.  

HINT:  You can replace ‘MyTheme’ in the filename with the name of your custom 
theme. 

3. If the layer palette window is not open, click “Window > Layers”. 

• The Layer window contains Layer set folders with subfolders of the 
different themeable elements (i.e. browser > Logos/Misc., RSS, 
Search/Go Buttons, etc.). Edit the particular layers of components 

from the layers palette to create your new theme in the 
SDK_MyTheme_Template.psd file you created at the beginning of Step Four. 

5. Once you are satisfied with your new theme you are ready to begin 
transferring all your graphic components into the following six (6) files within 
this SDK: 

a)NS_FUSION_browser_bookmarks_prefs.psd b) NS_FUSION_browser_Icons.psd 

c) NS_FUSION_browser_sidebar.psd d) NS_FUSION_browser_spui_base.psd 

e) NS_FUSION_global_Tabs.psd f) NS_FUSION_global_Toolbar.psd 

 

TIP:  Keep your file (MyTheme\SDK_Photoshop\SDK_MyTheme_Template.psd) 
from Step Four open at all times when transferring graphics. 
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See “Step Five: Transferring your new theme graphic components” on page 14 of 
this document for detailed information on transferring your graphics from the 
SDK_MyTheme_Template.psd file.  
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Step Five: Transferring your new theme graphic 
components 
Step Five contains the procedures for correctly transferring your graphics from 
the file you just completed in “Step Four: Use the NS_SDK_Fusion_Template.psd 
” on page 12.  

This tool provides a visual for graphic positioning within the browser. To ensure 
correct transfer, follow each procedure carefully. 

 

About these files 

This SDK includes six (6) Photoshop files, each containing layers allocated with 
individual graphic components. At the top of each file you will see an image of 
the Theme Component Graphic (FUSION Browser intact) with numbers 
associated with each graphic component (i.e. “Theme Composite of Assembled 
Graphic Components”). 

Example 3: Theme Composite of Assembled Graphic Components. 

 

Underneath the “Theme Composite of Assembled Graphic Components”, there 
are individual, numbered graphic components. The number of each graphic 
component coincides with its number in the above “Theme Composite of 
Assembled Graphic Components” (Fusion Browser). 

The numbers correlate with the numbers of the individual theme components (for 
example, the numbers 1 – 21 under the “Theme Composite of Assembled 
Graphic Components” correlate to the numbers 1 – 21 of the “Individual Fusion 
Theme Components for Browser”. 
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NOTE:  The text-based file numbers are located on the top layer, entitled: 
"Numbers/Descriptions". 

Example 4: Individual Fusion Theme Components for Browser. 

 

To transfer graphics from NS_SDK_Fusion_Template.psd (your new theme you 
created in Step Four) to these pages, follow the instructions in the following 
section. 
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Part I: How to use the files 

To complete the procedures detailed in Step Five, you may either open all six (6) 
files, or work through the six on a file-by-file basis: 

a)NS_FUSION_browser_bookmarks_prefs.psd b) NS_FUSION_browser_Icons.psd 

c) NS_FUSION_browser_sidebar.psd d) NS_FUSION_browser_spui_base.psd 

e) NS_FUSION_global_Tabs.psd f) NS_FUSION_global_Toolbar.psd 

 
1. Launch Photoshop and open all six (6) files from 

\MyTheme\SDK_Six_Photoshop_Templates. 
2. Save a copy of each file with the custom theme name 

NS_Fusion_browser_bookmark_pref.psd 

NOTE:  You can replace “Fusion” in the file name with the name of your custom 
theme. 

Before you begin 

Before you begin, be aware that you may need to turn off those layers of your 
NS_SDK_Fusion_Template.psd that overlap with the graphic you are transferring 
(turn off the eye [ ]on the layers palette).  

For example: 

• Turn off the layer set entitled NAV Round Buttons.  

• Turn off the individual text layer called “Netscape.com - Netscape 
Browser” located within the layer set call “Chrome Background”. 

Example 5: \MyTheme\SDK_Photoshop\NS_SDK_Fusion_Template.psd, overlapping layers turned off. 
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Part II: Select, Copy, Paste Into… 

1. Go back to the \MyTheme\SDK_Photoshop\SDK_MyTheme_Template.psd that 
you completed in Step Four: Use the NS_SDK_Fusion_Template.psd. 

2. Click the selection Tool in the Photoshop toolbox.  

• Ensure your Info palette is open (scroll to Window > Info to open). 

Example 6: Selection tool selected in Photoshop mode. 

 

 

3. Using your selection tool, click and drag around your graphic until you see the 
width & height information in the Info palette. 

• For example, in the ‘throbber-bg.png’ graphic, select a width of 58 
pixels and a height of 60 pixels. (i.e. the size of the embeded slices 
of the graphic, in this case in the 
NS_FUSION_browser_bookmarks_prefs.psd file). 

Example 7: Selection tool selected in Photoshop mode. 

 

• Open the Info Palette by clicking Window, then Info and check the 
height and width of your image.  
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NOTE: If the graphic in the “SDK_MyTheme_Template.psd has transparency, hide 
layers below the graphic in your design so that the transparency remains 
intact. 

Example 8: Info Palette showing width W: and Height H: of graphics. 

 

• Sizes can be found on each of the six (6) Graphic Component files in 
the SDK_Six_Photoshop_Templates folder. I.E. “NS_Fusion(or your 
Theme Name)_browser_bookmarks_prefs.psd” and on the table 
supplied on page 16 of this document. 

4. Press CTRL+Shift+C to copy your graphic selection from your 
\MyTheme\SDK_Photoshop\SDK_MyTheme_Template.psd. 

5. Return to the file you are transferring to (for example, your 
NS_FUSION_browser_bookmarks_prefs.psd file). 

6. In the Photoshop file, click the layer name in the layers palette to highlight 
the layer that contains the graphic you want to transfer (for example, click 
throbber-bg.png layer).  

HINT:   Select the move tool in Photoshop then hold down the Command or Control 
key and click the graphic on the canvas to select that particular layer. 

• While the layer containing the graphic (i.e. throbber-bg.png)you are 
transferring is highlighted, hold down the Control key (CTRL) and 
click on the graphic layer. This automatically selects the graphic in 
the highlighted layer. 

7. Press the Delete Button. This deletes the current graphic. 

8. Go to the Edit menu, and click Paste Into. This pastes your new theme 
graphic in the precise location of the old graphic. 

NOTE: Follow these steps for all (six) 6 files for each graphic component. 



Adapting the Default Fusion Theme  

Step Five: Transferring your new theme graphic components 19 

Part III: Graphic Components  

This section describes the graphic components that work in conjuction with each 
of the six (6) pages to which you are transferring your new theme graphics. The 
following Photoshop files and their associated layers are detailed: 

NS_FUSION_browser_bookmarks_prefs.psd .................................21 

NS_FUSION_browser_Icons.psd ....................................................23 

NS_FUSION_browser_spui_base.psd.............................................25 

NS_FUSION_browser_sidebar.psd .................................................29 

NS_FUSION_global_Tabs.psd .........................................................30 

NS_FUSION_global_Toolbar.psd ....................................................32 

 

Remember to test the changes to your theme (see “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this tutorial) as you work. 

Adding Complexity to Graphic #2  

If you want more complexity in your background graphic (graphic #2: 
“background-top-gradient.png”) withing the SDK_Six_Photoshop_Templates 
within the MyTheme_browser_bookmarks_pres.pds (or refer to page 16 in this 
document), use the guidelines below when selecting your dimensions.  

1. If graphic #2 does not repeat and you want an entire background graphic 
instead, you should make the “background-top-gradient.png” graphic 1400px 
wide by 59px high. 

2. Repeating tiled backgrounds can also vary in width by 59px high. 
 

NOTE: Varying the height or width of any repeating background graphic (such as 
graphic #2) will not break your theme. 

3. Overwrite graphic #2 called the “background-top-gradient” in the correct 
Directory Folder, in this case “\MyTheme\MyTheme.jar\browser” folder in 
Step 7. 

Adding Complexity to Graphics #117-#124  

 

NOTE: If you wish to have a background image in the container that holds the 
menubar (to the left of graphic #9), or the container that holds the window 
controls (graphics 117-124 within the “MyTheme_Global_Icons.psd” in the 
“SDK_Six_Photoshop_Templates.psd” folder or refer to page 16 in this 
document.) you have to create your own background graphic, that is at least 
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22px high and tiles horizontally. These tasks are described in the sections 
“Creating a Background Image for the Main Menubar” on page 56 and 
“Creating a background image for the Window Controls” on page 57. These 
sections also describe how to use the master CSS to get the desired 
background images on these components in your theme. 

4. Overwrite graphic #117 -#124 in the correct Directory Folder, in this case 
“\MyTheme\MyTheme.jar\browser\Global\Icons” folder in Step 7. 
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NS_FUSION_browser_bookmarks_prefs.psd 

1

 
 

throbber-bg.png 
Size W:58 x H:60 pixels 

2

 
 

background-top-gradient.png 
Size W:1 x H:59 pixels 
 
Note: This graphic will repeat 
itself horizontally. 

3

  
addressbar.png 
Size W:500 x H:25 pixels 

4

  

addressbar_slice.pn 
Size W:1 x H:25 pixels 
 
Note: This graphic will repeat 
itself horizontally. 

5

 
  

popup-blocked.png 
Size W:16 x H:14 pixels 

6

  
textbar-dropmarker.png 
Size W:12 x H:28 pixels 

7

  
go-button.png 
Size W:26 x H:28 pixels 

8

  
searchbar-button.png 
Size W:57 x H:28 pixels 

9

  
titlebar-separator.png 
Size W:153 x H:24 pixels 

10

 
 

page-livemarks.png 
Size W:32 x H:13 pixels 

11

  
textbar-left.png 
Size W:200 x H:28 pixels 

12

  

textbar-slice.png 
Size W:1 x H:28 pixels 
 
Note: This graphic will repeat 
itself vertically. 

13

 
 

new_tab_ovr.png 
Size W:22 x H:13 pixels 

14

 
 

new_tab.png 
Size W:22 x H:13 pixels 

15

 
 

tab-inactive-close.png 
Size W:9 x H:9 pixels 

16

 
 

tab-active-close.png 
Size W:9 x H:9 pixels 

17

  
all_tabs.png 
Size W:60 x H:28 pixels 
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18

  
all_tabs_ovr.png 
Size W:60 x H:28 pixels 

19

 
 

addbookmark_ovr.png 
Size W:23 x H:18 pixels 

20

 
 

addbookmark.png 
Size W:23 x H:18 pixels 

21

  
Options.png 
Size W:238 x H:34 pixels 
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NS_FUSION_browser_Icons.psd 

22

 

 

nav_large.png  
Size W:160 x H:128 pixels 

23

 

 

functional_large.png  
Size W:288 x H:128 pixels 

24

 

 

functional_large_2.png  
Size W:256 x H:128 pixels 

25

 

 

nav_small.png  
Size W:115 x H:92 pixels 

26

 

 

functional_small.png  
Size W:207 x H:92 pixels 

27

 

 

functional_small_2.png  
Size W:184 x H:92 pixels 

28

 

 

site-settings-large.png  
Size W:26 x H:104 pixels 
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29

  
mail_sm.png  
Size W:19 x H:19 pixels 

30

 
 

close_x.gif  
Size W:13 x H:12 pixels 

31

 
 

close_x_hot.gif  
Size W:13 x H:12 pixels 

32

 
 

sc_popup_help_icon.png  
Size W:15 x H:16 pixels 

33

 
 

security_center.png  
Size W:43 x H:15 pixels 

34

 
 

messagebar-warning.png  
Size W:15 x H:15 pixels 

35

  

trust-levels-large.png  
Size W:164 x H:46 pixels 

36

 
 

combined-trust-generic.gif  
Size W:63 x H:17 pixels 

37

 
 

combined-trust-small.png  
Size W:128 x H:68 pixels 
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NS_FUSION_browser_spui_base.psd 

38

 

 

gradient.png  
Size W:10 x H:525 pixels 
 
Note: This graphic has 
been scaled down to fit on 
this page. 

39

 

 

box-left-edge.png  
Size W:6 x H:165 pixels 

40

 
 

bttn_dwnarrow.png  
Size W:12 x H:12 pixels 

41

 
 

bttn_uparrow.png  
Size W:12 x H:12 pixels 

42

 
 

spui-plusminus.png  
Size W:24 x H:12 pixels 

43

 

 

box-background-fade.png  
Size W:2 x H:163 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

44

 

 

box-right-edge.png  
Size W:6 x H:165 pixels 

45

 
 

inset_bttm_1.png  
Size W:5 x H:5 pixels 
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46

 
 

inset_bttm_2.png  
Size W:5 x H:5 pixels 

47

 
 

inset_bttm_3.png  
Size W:5 x H:5 pixels 

48

 
 

hide-options.png  
Size W:68 x H:12 pixels 

49

 
 

show-options.png  
Size W:66 x H:10 pixels 

50

 
 

spui-go-blue.png  
Size W:29 x H:15 pixels 

51

 
 

spui-list-item-blue.png  
Size W:3 x H:3 pixels 

52

 
 

inset_mid_1.png  
Size W:5 x H:5 pixels 

53

 
 

inset_mid_2.png  
Size W:5 x H:5 pixels 

54

 
 

inset_mid_3.png  
Size W:5 x H:5 pixels 

55

  
spui_rnd_pop.png  
Size W:15 x H:24 pixels 

56

  

spui_mid_pop.png  
Size W:10 x H:24 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

57

  
spui_plus_pop.png  
Size W:15 x H:24 pixels 

58

 
 

inset_top_1.png  
Size W:5 x H:5 pixels 

59

 
 

inset_top_2.png  
Size W:5 x H:5 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

60

 
 

inset_top_3.png  
Size W:5 x H:5 pixels 

61

  
spui_rnd_ovr.png  
Size W:15 x H:24 pixels 

62

  

spui_mid_ovr.png  
Size W:10 x H:24 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

63

  
spui_rt_ovr.png  
Size W:15 x H:24 pixels 
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64

  
srch_rnd_pop.png  
Size W:12 x H:24 pixels 

65

  
srch_minus_pop.png  
Size W:10 x H:24 pixels 

66

  
srch_plus_pop.png  
Size W:10 x H:24 pixels 

67

  
srch_go_bttn_pop.png  
Size W:30 x H:24 pixels 

68

  
spui_rnd.png  
Size W:15 x H:24 pixels 

69

  

spui_mid.png  
Size W:10 x H:24 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

70

  
spui_rt.png  
Size W:15 x H:24 pixels 

71

  
srch_rnd.png  
Size W:12 x H:24 pixels 

72

  

srch_mid_pop.png  
Size W:5 x H:24 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

73

  

srch_mid.png  
Size W:5 x H:24 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

74

  
srch_minus.png  
Size W:10 x H:24 pixels 

75

  
srch_plus.png  
Size W:10 x H:24 pixels 

76

  
srch_go_bttn.png  
Size W:30 x H:24 pixels 

77

  
spui-button-left.png  
Size W:9 x H:25 pixels 

78

  

spui-button-slice.png  
Size W:3 x H:25 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

79

  
spui-button-right.png  
Size W:10 x H:25 pixels 

80

  
spui-over-button-left.png  
Size W:9 x H:25 pixels 
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81

  

spui-over-button-
slice.png  
Size W:3 x H:25 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

82

  
spui-over-button-
right.png  
Size W:10 x H:25 pixels 

83

  
spui-up-button-left.png  
Size W:9 x H:25 pixels 

84

  

spui-up-button-slice.png  
Size W:3 x H:25 pixels 
 
Note: This graphic will 
repeat itself horizontally. 

85

  
spui-up-button-right.png  
Size W:10 x H:25 pixels 
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NS_FUSION_browser_sidebar.psd 

86

  
sbar-close-hov.png  
Size W:18 x H:28 pixels 

87

  
sbar-close.png  
Size W:18 x H:28 pixels 

88

  
sbar-open-hov.png  
Size W:23 x H:28 pixels 

89

  
sbar-open.png  
Size W:23 x H:28 pixels 

90

 
 

sidebar-panel-arrow-
down.png  
Size W:11 x H:11 pixels 

91

 
 

sbpicker-arrow.png  
Size W:11 x H:11 pixels 

92

  
sbar-top.gif  
Size W:400 x H:31 
pixels 

93

 
 

grip-hrz-after-act.gif  
Size W:50 x H:5 pixels 

94

  

grip-vrt-after-act.gif  
Size W:5 x H:50 pixels 

95

  

grip-vrt-before-act.gif  
Size W:5 x H:50 pixels 

96

 
 

grip-hrz-after.gif  
Size W:50 x H:5 pixels 

97

 
 

grip-hrz-before-act.gif  
Size W:50 x H:5 pixels 

98

  

grip-vrt-after.gif  
Size W:5 x H:50 pixels 

99

  

grip-vrt-before.gif  
Size W:5 x H:50 pixels 

100

 
 

grip-hrz-before.gif  
Size W:50 x H:5 pixels 

101

  

splitter-bg.png  
Size W:1 x H:28 pixels 
 
Note: This graphic will 
repeat itself 
horizontally. 
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NS_FUSION_global_Tabs.psd 

102

  
tab_active_left.png  
Size W:4 x H:28 pixels 

103

  

tab_active_slice.png  
Size W:1 x H:28 pixels 

Note: This graphic will repeat 
itself horizontally. 

104

  
tab_active_stretch.png  
Size W:215 x H:28 pixels 

105

  
tab_active_right.png  
Size W:5 x H:28 pixels 

106

  
tab_inactive_left.png  
Size W:6 x H:28 pixels 

107

  

tab_inactive_slice.png  
Size W:1 x H:28 pixels 

Note: This graphic will repeat 
itself horizontally. 

108

  
tab_inactive_right.png  
Size W:6 x H:28 pixels 

109

 
 

tab-chevron-hov2.png  
Size W:13 x H:9 pixels 

110

 
 

tab-chevron2.png  
Size W:13 x H:9 pixels 

111

  

tabstrip-bottom.png  
Size W:1 x H:28 pixels 

Note: This graphic will repeat 
itself horizontally. 

112

 
 

tabs_dropmarker.png  
Size W:7 x H:4 pixels 

113

  
Filepicker.png  
Size W:72 x H:24 pixels 

114

 
 

bookmark-folder-closed-
new.png  
Size W:16 x H:16 pixels 

115

 
 

bookmark-folder-open-
new.png  
Size W:16 x H:16 pixels 

116

 
 

bookmark-item.png  
Size W:16 x H:16 pixels 

117

 
  

window-control-maximize-
h.png 
Size W: 14 x 13px 

118

 
 

window-control-
maximize.png 
Size W: 14 x 13px 
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119

 
 

window-control-restore.png 
Size W: 14 x 13px 

120

  
window-control-
minimize.png 
Size W: 14 x 13px 

121

 
 

window-control-close.png 
Size W: 14 x 13px 

122

 
 

window-control-restore-
h.png 
Size W: 14 x 13px 

123

 
 

window-control-minimize-
h.png 
Size W: 14 x 13px 

124

 
 

window-control-close-h.png 
Size W: 14 x 13px 
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NS_FUSION_global_Toolbar.psd 

125

 
 

arrow_l_ovr.png  
Size W:16 x H:11 pixels 

126

 
 

arrow_r_ovr.png  
Size W:16 x H:11 pixels 

127

 
 

bck_r_top.png  
Size W:14 x H:16 pixels 

128

 
 

arrow_l_prs.png  
Size W:16 x H:11 pixels 

129

 
 

arrow_r_prs.png  
Size W:16 x H:11 pixels 

130

  

bck_mid_tile.png  
Size W:5 x H:54 pixels 
 
Note: This graphic will repeat 
itself horizontally. 

131

 
 

multibar-drop-over.png  
Size W:11 x H:8 pixels 

132

 
 

arrow_l.png  
Size W:16 x H:11 pixels 

133

 
 

arrow_r.png  
Size W:16 x H:11 pixels 

134

 
 

multibar-bg-top.png  
Size W:2 x H:2 pixels 
 
Note: This graphic will repeat 
itself horizontally. 

135

 
 

multibar-drop-press.png  
Size W:11 x H:8 pixels 

136

 
 

multibar-drop.png  
Size W:11 x H:8 pixels 

137

  
flex-space.png 
Size W:32 x H:32 pixels 

138

  
space-icon.png  
Size W:32 x H:32 pixels 

139

 
 

bck_r_mid.png  
Size W:14 x H:1 pixels 
 
Note: This graphic will repeat 
itself vertically. 

140

 
 

multibar-bg-bottom.png  
Size W:2 x H:2 pixels 
 
Note: This graphic will repeat 
itself vertically. 
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141

 
 

toolbarbutton-
dropmarker.png 
Size W:11 x H:11 pixels 
 
 

142

 
 

bck_r_bttm.png  
Size W:14 x H:13 pixels 

143

 
 

mcontrol-top-over.png  
Size W:84 x H:16 pixels 

144

 
 

mcontrol-top-press.png  
Size W:84 x H:16 pixels 

145

 
 

mcontrol-top.png  
Size W:84 x H:16 pixels 

146

  
separator-icon.png  
Size W:2 x H:32 pixels 

147

 
 

mcontrol-left-button-
over.png  
Size W:42 x H:16 pixels 

148

 
 

mcontrol-mid-over.png  
Size W:84 x H:1 pixels 
 
Note: This graphic will repeat 
itself vertically. 

149

 
 

mcontrol-right-button-
over.png  
Size W:42 x H:16 pixels 

150

 
 

mcontrol-left-button-
press.png  
Size W:42 x H:16 pixels 

151

 
 

mcontrol-mid-press.png  
Size W:84 x H:1 pixels 
 
Note: This graphic will repeat 
itself vertically. 

152

 
 

mcontrol-right-button-
press.png  
Size W:42 x H:16 pixels 

153

 
 

mcontrol-left-button.png  
Size W:42 x H:16 pixels 

154

 
 

mcontrol-mid.png  
Size W:84 x H:1 pixels 
 
Note: This graphic will repeat 
itself vertically. 

155

 
 

mcontrol-right-button.png  
Size W:42 x H:16 pixels 

 
 

• Test the changes to your theme in “Step Eight: As you go… Testing the 
changes to your Theme” on page 49 of this tutorial. 
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Step Six: Optimize Your New Theme Graphics 
After you have created your new theme in the 
\MyTheme\SDK_Photoshop\SDK_MyTheme_Template.psd, and overlaid each 
graphical element within the specified image location within the six (6) files, you 
must optimize all graphics on each page.  

For ImageReady users there are tools included in this SDK to speed up the 
process of Theme development. This aproach is recommended for a few reasons: 

• Photoshop works in conjunction with ImageReady to speed up 
optimization. 

• You can easily automate basic routine tasks with ImageReady. 

• Slices and filenames are in place within the included ImageReady files, 
saving you time. 

To optimize your files 

Work on each of the six (6) files in ImageReady mode. To switch from Photoshop 
to ImageReady mode, click the ImageReady icon at the base of your Photoshop 
tools palette. 

Example 9: Switching from Photoshop to ImageReady mode. 

 

1. Select the Slice Select Tool in the tools palette (in ImageReady mode), and 
hold down the Shift Key. Click on all the embedded slices around each graphic 
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(blue outlines represent slices). Turn off the layer in the layers palette called 
“Background” this is also noted on each of the six (6) files. 

Example 10: Screened back file in ImageReady with Slice Select Tool selected. 

 

2. Select all graphics within each “Individual Components” section on the six (6) 
files. Each “Individual Components” section on the page correlates to the jar 
folder structure in the SDK show in Step 4: Example 4. This will ensure that 
the images are saved in the correct folder locations in the SDK. 

3. In the SDK_Six_Photoshop_Templates folder there is more than one file that 
has more than one “Individual Components” section. The files that have more 
than one section on them are: “MyTheme_browser_bookmarks_prefs.psd”, 
MyTheme_global_tabs.psd”, and “MyTheme_browser_sidebar.psd”. They are 
segmented with different background colors to help differentiat the different 
“Individual Components” sections. 

Example 11: Background layer turned off. 
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4. Go to the File Menu and choose “Save Optimized As” 

Example 12: File Menu Save Optimized As… 
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5. An Output Settings window appears. 

Example 13: File Menu Save Optimized As… 

 
 

6. Choose the following in the Output Settings window:  
• Format:  Images Only  

• Settings:  Custom 

• Slices:  Selected Slices 

 

To learn where to save your Optimized graphics, refer to “Step Seven: Where to 
Save Your Optimized Graphics” on page 38. 
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Step Seven: Where to Save Your Optimized Graphics 
You are now ready to save all of your graphics into the Directory folder that 
came with the SDK file: 
\NS_ThemeSDK\MyTheme\SDK_Photoshop\SDK_MyTheme_Template.psd.  

This section details which graphics go into which part of the Directory Folder for 
each of the six (6) pages you completed in “Step Five: Transferring your new 
theme graphic components”.  

It is most important that you put the graphics into the proper folders as 
indicated.  

All of the following filenames correspond with the graphics detailed in “Part III: 
Graphic Components” on page 19. Each of these correspond to Individual Fusion 
Theme Components listing on each of the following files below. 

NS_FUSION_browser_bookmarks_prefs.psd .................................40 

NS_FUSION_browser_Icons.psd ....................................................42 

NS_FUSION_browser_spui_base.psd.............................................43 

NS_FUSION_browser_sidebar.psd .................................................44 

NS_FUSION_global_Tabs.psd .........................................................46 

NS_FUSION_global_Toolbar.psd: ...................................................48 

 

NOTE:   For quick and easy reference to the Directory files you can use this the 
following “Quick file destinations reference” table for “Individual Theme 
Components” below. This table references where graphics (referenced by 
their appropriate numbers) are to be saved in the Theme jar. 
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NS_FUSION_browser_bookmarks_prefs.psd 

1. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\”  

2. Save all optimized graphics from the “Individual Fusion Theme Components 
for Browser” section to the SDK browser folder within the Directory Folder 
file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\”  

Example 14: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser”. 

 

 
3. Overwrite existing graphics #1 - #18 in this Directory Folder with your New 

Theme Graphics. 
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4. Save all optimized graphics from the “Individual Fusion Theme Components 
for Bookmarks” section to the SDK browser bookmarks folder within the 
Directory Folder file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\bookmarks\” 

Example 15: Directory Folder file: “\MyTheme\MyTheme.jar\browser\bookmarks”. 

 

5. Overwrite existing graphics #19 - #20 In this Directory Folder with your New 
Theme Graphics. 

6. Save all optimized graphics from the “Individual Fusion Theme Components 
for Preferences” section to the SDK browser prefs folder within the Directory 
Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\prefs\”  

Example 16: Directory Folder file: “\MyTheme\MyTheme.jar\browser\prefs”. 

 

 

7. Overwrite existing graphic #21 in this Directory Folder with your New Theme 
Graphics. 
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NS_FUSION_browser_Icons.psd 

1. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\icons\”  

2. Save all optimized graphics from the “Individual Fusion Theme Components 
for Icons” section to the SDK browser icons folder within the Directory Folder 
file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\Icons\”.  

Example 17: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\Icons”. 

 

 

3. Overwrite existing graphics #22 - #37 in this Directory Folder with your New 
Theme Graphics. 

 



Adapting the Default Fusion Theme  

Step Seven: Where to Save Your Optimized Graphics 43 

NS_FUSION_browser_spui_base.psd.  

1. Open the Directory folder that came with this SDK: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\spui\base\”. 

2. Save all optimized graphics from the “Individual Fusion Theme Components 
for SPUI Container” section to the SDK browser SPUI base folder within the 
Directory Folder file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\spui\base\”. 

Example 18: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\spui\base”. 

 

 

3. Overwrite existing graphics #38 -#85 in this Directory Folder file 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\spui\base\” with your New 
Theme Graphics. 
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NS_FUSION_browser_sidebar.psd 

1. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\sidebar” 

2. Save all optimized graphics from the “Individual Fusion Theme Components 
for the Sidebar” section to the SDK browser sidebar folder within the 
Directory Folder file: 
\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\sidebar\”  

Example 19: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\sidebar”. 

 

 

3. Overwrite existing graphics #86 - #92 in this Directory Folder file: 
\NS_ThemeSDK\MyTheme\MyTheme.jar\browser\sidebar\”with your New 
Theme Graphics. 

4. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\global\splitter”. 
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5. Save all optimized graphics from the “Individual Theme Components for the 
Sidebar (Splitter) section to the SDK global splitter folder within the Directory 
Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global\splitter\ 

Example 20: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global\splitter”. 

 

 

6. Overwrite existing graphics #93 -#101 in this Directory Folder file: 
\NS_ThemeSDK\MyTheme\MyTheme.jar\global\splitter\”with your New 
Theme Graphics. 
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NS_FUSION_global_Tabs.psd 

1. Open the Directory folder that came with this SDK called file: 
\NS_ThemeSDK\MyTheme\MyTheme.jar\global\tabs\”. 

2. Save all optimized graphics from the “Individual Fusion Theme Components 
for Tabs Directory”” section to the SDK Global Tabs folder within the Directory 
Folder file: \NS_ThemeSDK\MyTheme\MyTheme.jar\global\tabs\”  

Example 21: Directory Folder file: “\NS_ThemeSDK\MyTheme.jar\MyTheme\global\tabs”. 

 

3. Overwrite existing graphics #102 - #113 in this Directory Folder file 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\global\tabs\”with your New Theme 
Graphics. 

4. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\global\”. 

5. Save all optimized graphics from the “Individual Theme Components for 
Global Icon Bookmarks section to the SDK global folder within the Directory 
Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global\” 

Example 22: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global”. 
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6. Overwrite existing graphics #113 in this Directory Folder file: 
\NS_ThemeSDK\MyTheme\MyTheme.jar\global\splitter\” with your New 
Theme Graphics. 

7. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\global\icons\”. 

8. Save all optimized graphics from the “Individual Theme Components for 
Global Icon Bookmarks section to the SDK global folder within the Directory 
Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global\icons\” 

Example 23: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global\icons”. 

 

9. Overwrite existing graphics #114 - #116 in this Directory Folder file 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\global\tabs\” with your New Theme 
Graphics. 
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NS_FUSION_global_Toolbar.psd: 

1. Open the Directory folder that came with this SDK called file: 
“\NS_ThemeSDK\MyTheme\MyTheme.jar\global\toolbar”. 

2. Save all optimized graphics from the “Individual Fusion Theme Components 
for the Toolbar” section to the SDK Global toolbar folder within the Directory 
Folder file: \NS_ThemeSDK\MyTheme\MyTheme.jar\global\toolbar\”  

Example 24: Directory Folder file: “\NS_ThemeSDK\MyTheme\MyTheme.jar\global\toolbar”.  

 

 

3. Overwrite existing graphics #117 - #148 in this Directory Folder file: 
“\NS_ThemeSDK\MyTheme\global\toolbar\” with your New Theme Graphics. 

 



Adapting the Default Fusion Theme  

Step Eight: As you go… Testing the changes to your Theme 49 

Step Eight: As you go… Testing the changes to your 
Theme 
It is important to test your theme as you create it throughout this tutorial. 
Testing allows you to isolate any theming issues as they might occur. Refer to 
this section periodically if you need to review testing procedures. 

NOTE: Testing will be successful only in a PC environment. 

1. Save your graphics asset to the different folders and subfolders within the 
\NS_ThemeSDK\MyTheme folder overwriting files when necessary. 

2. Using Winzip or Stuffit Expander, add the entire contents the 
\NS_ThemeSDK\MyTheme folder to a .ZIP file archive. 

• Right click on one of the selected items and select “Send To”. In the 
Sub Menu select “Compressed (zipped) folder”. 

 

Example 25: Context Menu Window 

 

 

• Click ‘OK’ and and rename the zip file to MyTheme.jar. 
3. Launch Netscape and click Tools from the main menu bar. 

4. Open the Themes dialog. A dialog window appears showing the themes 
installed in Netscape. 
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Example 26: Themes Dialog Window. 

 

5. Click and drag your newly created MyTheme.jar file into this window. This 
triggers it to install. 

6. Double click on your theme from the list. The text "Restart Netscape to use" 
appears under the icon of your theme. 

7. Restart Netscape and observe your theme. 
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Changing Text and Font Styles of Browser Elements 
The master .css file is an easy and powerful way to theme some of the non-
graphical elements of the Netscape 8 browser. Use the steps provided below to 
guide you. 

This section contains instructions for the following procedures: 

Loading the Master .CSS File...........................................................52 

Changing Application Window Default Colors (optional) ...............53 

Changing Tab Browser HTML Fonts ................................................54 

Changing Site Control Popup Window Color and Text Styles .........55 

Changing the Appearance of the Status Bar ...................................57 

Changing HTML Text Styles of the Titlebar HTML ...........................59 

Changing the Main Menubar Menu items Appearance....................60 

Changing Hover Text Styles of Personal Toolbar Bookmarks.........61 

Changing the Spui Button Text Color..............................................62 

Changing the Sidebar Panel Colors.................................................63 

Changing Sidebar HTML Text Styles ...............................................65 

Changing Sidebar TAB HTML Text Styles ........................................66 

Creating a Background Image for the Sidebar Panels....................66 

Creating a Background Image for the Main Menubar.....................67 

Creating a Background Image for the Window Controls within the 
Menubar ..........................................................................................68 

Changing the Main Menubar HTML Text Appearance .....................68 

 



Adapting the Default Fusion Theme  

Changing Text and Font Styles of Browser Elements 52 

Loading the Master .CSS File 

1. Navigate to \NS_ThemeSDK\MyTheme\browser, and locate the file 
“master.css”. 

2. Right-click on the file “master.css” and select “Edit with Notepad” 
(alternatively you can edit this file with your favorite text editor). 

 

Example 27: Loading the master.css file into Notepad. 
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Changing Application Window Default Colors (optional) 

Example 28: Browser Component with solid background color using the master.css. 

 
 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52. 

2. Locate the line: /*background-color: #000000 !important;*/ on line 38 in the 
master css. 

3. Delete the characters /* and */ from the line. It should now read: 
background-color: black !important;  

4. Replace the text ‘#000000’ with your desired color. For example, if you 
wanted your background hex color to be gray for each window in Netscape, 
line 38 should read: background-color: #eeeee !important;  
 

HINT: If your background gradient fades starts at one color, and ends at another 
color, set the hex background-color in this step to the color of what the 
gradient fades to. This is so the browser colors appear seamless with the 
gradient. 

5. Click File > Save to save the master.css file. 

6. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

7. Confirm that the background color for the window is in fact the color you 
specified on line 38 of the master.css file. 
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Changing Tab Browser HTML Fonts 

Example 29: Tab Browser with HTML fonts. 

 

 
1. Load the master CSS file from the procedure described in “Loading the master 

CSS File” on page 52. 

2. Go to line 46 of the master.css file that reads /*color: #000000 !important;*/ 

3. Uncomment this line so it reads only: color: #000000 !important 

4. Replace “#000000” on line 46 with your desired hex color for the active tab’s 
text. 

5. Go to line 47 of the master css file that reads /*font-family: Arial, sans-serif, 
verdana !important;*/ 

6. Uncomment this line so it reads - font: font-family: Arial, sans-serif, verdana 
!important; 

7. Replace ‘Arial, sans-serif, verdana’ on this line with the font families you wish 
to use. 

8. Goto line 52 of the master.css which reads /*color: #eeeeee !important;*/ 

9. Uncomment this line so that it just reads color: #eeeeee !important; 

10.Replace color: #eeeeee with the hex color you wish the inactive tab’s text to 
use. 

11.Click File > Save to save the master.css file. 

12.Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

13.Confirm that the active and inactive tab’s font and appearance is the same 
that you have supplied in the master.css file. 
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Changing Site Control Popup Window Color and Text Styles 

Example 30: Site Control Window. 

 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. Locate the line: /*background-color: #ffffff! important;*/ on line 201. 

3. Delete the characters /* and */ from the line so it reads: background-color: 
#ffffff !important;  

4. Replace the text ‘#ffffff‘ with your desired hex color for the theme’s site 
control popup window. For example, if you wanted a red background color for 
the site controls popup window, line 201 should now read: background-color: 
#ff0000 !important; 

5. Locate the line /*color: #ff0000 !important;*/ on line 202. 

6. Delete the characters /* and */ from the line so it reads background-color: 
#ff0000 !important;  

7. Replace the text #ff0000 with your desired hex color for the text in the site 
controls popup. For example, if you want green text in the site controls 
popup, line 199 should now read: color: #00ff00 !important; 

8. Locate the line /*background-color: #00ff00 !important;*/ on line 206. 

9. Delete the characters /* and */ from the line so it reads background-color: 
#00ff00 !important; 
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10.Replace the text “#00ff00” on line 206 with your desired hex background 

color for the section captions of the site control popup. For example, if you 
want black background color for the captions, line 206 should now read: 
background-color: #000000 !important; 

11.Locate the line /*color: #ff0000 !important;*/ on line 207. 

12.Delete the characters /* and */ from the line so it reads color: #ff0000 
!important; 

13.Replace the text “#ff0000” with your desired hex color for the caption font 
text. For example, if you want white caption text color, line 207 should read 
color: #ffffff; 

14.Save the master.css file by clicking File then Save. 

15.Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

16.Confirm that the colors for the site controls popup are in fact the colors you 
specified on line 198-199 of the master.css file. 
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Changing the Appearance of the Status Bar  

Example 31: Status bar. 

  

 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. To change the font color of the statusbar text, goto line 136 of the master css 
file which reads: /*color: #0000ff !important;*/ 

3. Uncomment line 136 so it reads color: #0000ff !important; 

4. Replace “#0000ff” with your desired hex code of the color for the status bar. 
For example, if you want red status bar text, line 136 should now read 
background-color: #ff0000!important. 

5. To change the background color of the status bar, goto line 137 of the master 
CSS file that reads: “/*background-color: #ffcf94 !important;*/” 

6. Uncomment line 137 so it reads: background-color: #ffcf94 !important; 

7. Replace “#ffcf94” with your desired hex color code of the color you wish the 
status bar to be. For example if you wanted to change the background color 
of the statusbar to green, line 137 should now read background-color: 
#00ff00 !important. 

8. Save the Master css file by clicking File then Save. 

9. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

10.Confirm that the statusbar color is the same that you have supplied in the 
master.css 
 

NOTE: You can also have a background image on the statusbar. The instructions in 
this note describe how to easily do this.  

1. Create an image of your statusbar background graphic so it repeats horizontally. 
The height should be at least 22px. 

2. Save your background image  as the file “statusbar-bg.png” in the jar directory 
“browser”. 

3. Load the master CSS file. 

4. Goto line 138 of the master CSS file and uncomment it so it reads: “background-
image: url(“statusbar-bg.png”) !important; 

5. Goto line 139 and uncomment it so it reads: “background-repeat: both !important; 

6. Click File > Save to save the master CSS file. 
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7. Test your changes using the procedures outlined in “Step Eight:  As you go... 
Tesing the changes to your Theme on page 43 of this SDK.  
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Changing HTML Text Styles of the Titlebar HTML 

Example 32: Title Bar HTML. 

 
 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. Goto line 123 of the master CSS file which reads: “/*font-family: Arial, sans-
serif, verdana !important;*/” 

3. Uncomment line 123 so it reads font-family: Arial, sans-serif, verdana 
!important; 

4. Replace “Arial” in line 123 to the font face you would like to use 

5. Goto line 124 of the master CSS file which reads: /*font-weight: bold 
!important;*/ 

6. Uncomment line 124 so it reads font-weight: bold !important; 

7. Replace “bold” with the font-weight you wish the text in the title bar to have. 
This is either “none” for just plain text, “bold” for bold text, and italic for 
italicized text or “underline” for underlined text. 

8. Goto line 125 of the master CSS file which reads: /*font-size: 12pt 
!important;*/ 

9. Uncomment line 125 so that it appears as: font-size: 12pt !important; 

10.Replace “12” in line 125 with the font size you wish the titlebar text to be. 

11.Goto line 126 of the master CSS file which reads: /*color: #FFFFFF 
!important;*/ 

12.Uncomment line 126 so that it reads color: #FFFFFF !important; 

13.Replace “#FFFFFF” with your desired hex color value for the titlebar’s text. 

14.Click File > Save to save the master CSS file. 

15.Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

16.Confirm the titlebar’s text appearance is as expected. 
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Changing the Main Menubar Menu items Appearance 

Example 33: Screenshot of main Menubar menu. 

 

 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. To change the hover background color of main menubar menu items, go to 
line 71 of the master CSS file which reads: /*background-color: #371C14 
!important;*/ 

3. Uncomment line 71 so it reads: background-color: #371C14 !important; 

4. Replace #371C14 with your desired hex color value for the main menubar 
menuitems (when hovered over). 

5. Goto line 72 of the master css file that reads /*color: #00ff00 !important;*/ 

6. Uncomment line 72 so it reads: color: #00ff00 !important; 

7. Replace “#00ff00” on line 72 with your desired hex color value for the main 
menubar menu items (when hovered over). 

8. Click File > Save to save the master CSS file. 

9. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

10.Ensure that the main menubar menuitem hover behavior of the text operates 
as expected. 
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Changing Hover Text Styles of Personal Toolbar Bookmarks 

Example 34: Screenshot of Hover HTMLText on Toolbar. 

 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. Goto line 227 of the master CSS file that reads: /*font-size: 12pt 
!important;*/ 

3. Uncomment line 227 so it reads as: font-size: 12pt !important; 

4. Replace “12” in line 227 with your desired font size for the personal toolbar 
bookmark text. 

5. Goto line 228 of the master CSS file that reads: /*color: #000000 
!important;*/ 

6. Uncomment line 228 so it reads: color: #000000 !important; 

7. Replace “#000000” with your desired hex color value for the bookmark’s text. 

8. Change the hover state of a bookmark item on the personal toolbar; goto line 
232 of the master CSS file that reads /*text-decoration: underline 
!important;*/ 

9. Uncomment line 232 so it reads: color: text-decoration: underline !important. 

10.Replace “underline” with the text decoration you wish your bookmark item to 
have when the cursor hovers over it. This can be either “bold”, “underline”, 
“italic”, or “none”. 

11.Click File > Save to save the master CSS file. 

12.Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

13.Ensure that there is a bookmark item on the personal toolbar, and observe 
the hover state of the item. 
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Changing the Spui Panel Background Color for Search Field within Yellow 
Pages & Quickshopping Widgets 

 

 Example 35: Screenshot of Spui Panel Yellow Pages Widget. 

 

1. Open up the base.css from the ‘MyTheme.jar’ file. 
\MyThemeSDK\MyTheme.jar\browser\spui\base\. 

2. Go to line 293 which says “#spuiPill textbox { 

3. Add an attribute to this style called: background-color: #<your hex color> 
!important; 

4. Here you can also change the text color of the textbox by changing the 
existing color attribute in this css style. Currently it says “color: #a0a0a0;” 

 

Changing the Spui Button Text Color 

Example 36: Screenshot of Spui Button  

 

1. Open up the webmail.css from the ‘MyTheme.jar’ file. 
\MyThemeSDK\MyTheme.jar\browser\. 

2. Go to line 105 which says “#spuiPill textbox {“ 
3. Lines 106 – 109 is where the styles to change the appearance of the text of 

the webmail buttons etc. are located. Line 106 is where you change the 
attribute color to the hex color you need. (i.e. “color: #a0a0a0;”) 
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Changing the Sidebar Panel Colors 

Example 37: Screenshot of Sidebar Panel. 

 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. Goto line 150 of the master CSS file that reads: /*background-color: #00ff00 
!important;*/ 

3. Uncomment line 150 so it reads: background-color: #00ff00 !important; 

4. Replace “00ff00” in line 150 with your desired hex color value for the sidebar 
panel (this will be its default). 

5. Goto line 151 of the master CSS file which reads: /*border-top: 1px solid 
#344c52 !important;*/ 

6. Uncomment line 151 so it reads border-top: 1px solid #344c52 !important; 

7. Replace “#344c52” with your desired hex color value for the top border of 
each sidebar panel. 

8. Goto line 156 of the master css that reads: “/*background-color: red 
!important;*/” 

9. Uncomment line 156 so it reads: background-color: #ff0000 !important; 

10.Replace “#ff0000” in this line with your desired hex color value for the 
sidebar panel when the cursor hovers over it. 
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Changing the Appearance of the Sidebar Splitter 

Example 38: Screenshot of Sidebar Panel. 

 
 
1. Load the master CSS file from the procedure described in “Loading the master 

CSS File” on page 52. 

2. Go to line 246 of the master.css file that reads /*background-color: #00ff00 
!important;*/ 

3. Uncomment this line so it reads only: background-color: #00ff00 !important; 

4. Replace “#00ff00” on line 246 with your desired hex color for the sidebar 
splitter’s background color. 

5. Click File > Save to save the master.css file. 

6. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

7. Confirm that the sidebar splitter’s background color is the same that you have 
supplied in the master.css file. 
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NOTE: You can also have a background image tiling vertically in the sidebar splitter 
instead of a background color. The instructions in this note describe how to 
easily do this.  

8. Create an image of your sidebar splitter background graphic so it repeats 
vertically. The width should be at least 5px. 

9. Save your background image  as the file “sidebar-splitter-bg.png” in the jar 
directory “browser”. 

10. Load the master CSS file. 

11. Goto line 247 of the master CSS file and uncomment it so it reads: “background-
image: url("sidebar-splitter-bg.png") !important;” 

12. Goto line 248 and uncomment it so it reads: “background-repeat: repeat-y 
!important; 

13. Click File > Save to save the master CSS file. 

14. Test your changes using the procedures outlined in “Step Eight:  As you go... 
Tesing the changes to your Theme on page 43 of this SDK.  

 

Changing Sidebar HTML Text Styles 

Example 39: Screenshot of Sidebar HTML Text. 

 

1. Goto line 152 of the master CSS file which reads: /*color: #ff0000 
!important;*/ 

2. Uncomment line 152 so it reads: color: #ff0000 !important; 

3. Replace “#ff0000” in line 152 with your desired text color for the sidebar 
panel text. 

4. Goto line 157 of the master CSS that reads /*color: #0000ff !important;*/ 

5. Uncomment line 157 so it reads color: #0000ff !important; 

6. Replace “#0000ff” in this line with your desired hex color value for the 
sidebar panel text when hovered over. 

7. Click File > Save to save the master CSS file. 
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8. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

Changing Sidebar TAB HTML Text Styles 

Example 40: Screenshot of Sidebar Panels. 

 

 

1. Open the sidebar.css css from the ‘MyTheme.jar’ file. 
\MyThemeSDK\MyTheme.jar\browser\sidebar\. 

2. Add the color: property to the #sidebar-panel-picker 

 

 

Creating a Background Image for the Sidebar Panels 

Example 41: Screenshot of Sidebar Panels. 

 

1.  Create an image of your background graphic so it repeats horizontally. The   
     height of your slice should be at least 19px. 

3. Save your background graphic as the file “statusbar-bg.png” in the jar 
directory “browser”. 

4. Load the master.css file. 

5. Goto line 236 and uncomment it so it reads “background-image: 
url("backgrounds/sidebar-bg.png") !important;” 

6. Goto line 237 and uncomment it so it reads “background-repeat: both 
!important;” 

7. Click File > Save to save the master CSS file. 

8. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 
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NOTE:  You can also have a different background image display when a statusbar 
panel is hovered over. The instructions in this note describe how to easily do 
this. 

1. Create a background graphic for when the statusbar is hovered over so it repeats 
horizontally. The height of your slice should be at least 19px. 

2. Save your background image as the file “sidebar-bg-hover.png” in the the jar 
directory “browser”. 

3. Load the master.css file. 

4. Goto line 241 and uncomment it so it reads “background-image: url("sidebar-bg-
hover.png") !important;” 

5. Goto line 242 and uncomment it so it reads “background-repeat: both !important;” 

6. Click File > Save to save the master CSS file. 

7. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

 

Creating a Background Image for the Main Menubar 

Example 42: Screenshot of Main Menubar. 

 

1. Create an image of your background graphic so it repeats horizontally. The 
height of your slice should be at least 22px. 

2. Save your background image as the file "titlebar-bg-gradient.png" in the jar 
directory "browser". 

3. Load the master.css file. 

4. Goto line 215 and uncomment it so it reads: "background: none !important;"  

5. Goto line 216 and uncomment it so it reads: "background-image: 
url("titlebar-bg-gradient.png") !important;" 

6. Goto line 217 and uncomment it so it reads: "background-repeat: repeat-x 
!important;" 

7. Click File > Save to save the master CSS file. 

8. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 
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Creating a Background Image for the Window Controls within the Menubar 

Example 43: Screenshot of Main Menubar Window Controls 

 

1. Create an image of your background graphic so it repeats horizontally. The 
height of your slice should be at least 22px. 

2. Save your background image as the file "window-control-bg-gradient.png" in 
the jar directory "browser". 

3. Load the master.css file. 

4. Goto line 221 and uncomment it so it reads "background: none !important;"  

5. Goto line 222 and uncomment it so it reads "background-image: url("titlebar-
bg-gradient.png") !important;" 

6. Goto line 223 and uncomment it so it reads "background-repeat: repeat-x 
!important;" 

7. Click File > Save to save the master CSS file. 

8. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

Changing the Main Menubar HTML Text Appearance 

Example 44: Screenshot of Main Menubar HTML Text. 

 

1. Load the master CSS file from the procedure described in “Loading the master 
CSS File” on page 52.  

2. Goto line 77 of the master CSS file.  

3. Uncomment line 77 so that it appears as: font-size: 12pt !important; 

4. Replace “12” in line 77 with your desired font size for the menubar text. 

5. Goto line 78 of the master CSS file which reads: /*color: #ff0000 
!important;*/ 

6. Uncomment line 78 so that it reads color: #ff0000 !important; 

7. Replace “#ff0000” with the hex value of the color you wish the menubar text 
to be. 

8. Goto line 79 of the master CSS file that reads /*text-decoration: bold 
!important;*/ 

9. Uncomment line 79 so that it reads color: text-decoration: bold !important; 



Adapting the Default Fusion Theme  

Changing Text and Font Styles of Browser Elements 69 

10.Replace “bold” with your desired text decoration for the menubar text. This 
can be one of “bold”, “underline”, “italic”, or “none”. 

11.Goto line 80 of the master CSS that reads /*font-family: Arial, sans-serif, 
verdana !important;*/ 

12.Uncomment line 80 so that it reads font-family: Arial, sans-serif, verdana 
!important; 

13.Replace “Arial, sans-serif, verdana” on line 80 with your desired font for the 
menubar. 

14.Click File > Save to save the master CSS file. 

15.Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

 
 
 
Changing the Main Menubar HTML Text Appearance when the menubar is 
toggled to the left 

Example 45: Screenshot of Main Menubar HTML Text. 

 
1. Load the master CSS file from the procedure described in “Loading the master 

CSS File” on page 52. 

2. Go to line 72 of the master.css file that reads /*color: #0000ff !important;*/ 

3. Uncomment this line so it reads only: color: #0000ff !important; 

4. Replace “#0000ff” on line 72 with your desired hex color for main menubar 
text when it is toggled to the left. 

5. Click File > Save to save the master.css file. 

6. Test your changes using the procedures outlined in “Step Eight: As you go… 
Testing the changes to your Theme” on page 49 of this SDK. 

7. Toggle the main menubar to the left (if it’s not on the left side of the browser 
already) by right clicking anywhere on the toolbar and selecting “Toggle 
menubar position” from the context menu. 

8. Confirm that the color of the menubar when it is toggled to the left is the 
same as the hex color you supplied on line 72 of the master CSS file. 

 
 
 


