Of course there's also the FAQ links in the bottom right corner of the ITRC home page, but these link you to the US sites only, giving the Europeans no access :(
Frank Slootweg adds the following quote about HP FAQ's:
As far as I know there is no HP-UX FAQ specifically for the ITRC Forums, but there is a FAQ for the Usenet Newsgroup comp.sys.hp.hpux which I think should/could be used instead: ftp://rtfm.mit.edu/pub/faqs/hp/hpux-faq There is also be an HTML version of the FAQ (see 4.1.1 in the FAQ) at http://faqs.org/faqs/hp/hpux-faq/
Here's a shot at the questions that I've seen appear again and again. This script, which also works on Linux and AIX, will execute most of them and shows the system specifics in one like this, and does not need root rights:
a5:/ 101 # ux a5 HP-UX 11.00/64 U 9000/800/A500-7X/64 PA8700/750(2) pa-2.0 2048 Mb a5:/ 102 #
on PA-RISC, or on Itanium:
x1:/ 101 # ux x1 HP-UX 11.23/64 U rx1620/64 Itanium 2/1600(2) ia64 2037 Mb x1:/ 102 #
The script was updated on 27-05-2005 to implement the syscall ()
functionality as described
in
this thread, which not only makes it much faster, but also gives more
information if you're not root.
You can find out if your kernel supports 64bit binaries by issuing:
a5:/usr/local 110 > file /stand/vmunix /stand/vmunix: ELF-64 executable object file - PA-RISC 2.0 (LP64) a5:/usr/local 111 > getconf KERNEL_BITS 64 a5:/usr/local 112 > getconf HW_32_64_CAPABLE 1 a5:/usr/local 113 >
HP-UX 10.20 does not support 64bit objects
a5:/usr/local 108 > file pa*/bin/gcc pa11_32/bin/gcc: PA-RISC1.1 shared executable dynamically linked -not stripped pa20_32/bin/gcc: PA-RISC2.0 shared executable dynamically linked -not stripped pa20_64/bin/gcc: ELF-64 executable object file - PA-RISC 2.0 (LP64) a5:/usr/local 109 >
Provided your binary isn't stripped, and it is 32bit SOM
that info should be reveiled with odump -compunit
Provided your binary isn't stripped, and it is 64bit ELF (LP64)
that info should be reveiled with elfdump -dc
To see the libraries your library or object depends on, use
chatr
, which shows the dependencies it
wants, or ldd
, which shows the
dependencies that can be resolved.
You only need 64bit gcc if you have to build 64bit binaries. gcc/64 cannot build 32bit binaries, so if you need both, you need two versions/builds of gcc
In general, no. You only need a 64bit build of perl when you have to link to 64bit objects/libraries of other applications, such as Oracle. 32bit build Oracle does not play nice with 64bit build of perl or the other way round.
a5:/ 107 > echo "selclass qualifier system;info;wait;infolog" | /usr/sbin/cstm | grep "System Serial Number" System Serial Number...: AB12345678 a5:/ 108 >
a5:/wrk 105 > grep processor /var/adm/syslog/syslog.log Nov 5 13:10:54 a5 vmunix: 160 processor a5:/wrk 105 > ioscan -fnkC processor Class I H/W Path Driver S/W State H/W Type Description =================================================================== processor 0 160 processor CLAIMED PROCESSOR Processor a5:/wrk 106 > echo "selclass qualifier cpu;infolog" | /usr/sbin/cstm | grep "CPU Module" PA 8600 CPU Module 3.1 a5:/wrk 107 > echo "sc product cpu;il" | /usr/sbin/cstm | grep 'CPU Module' PA 8600 CPU Module 3.1 a5:/wrk 108 >
Or with Perl:
a5:/wrk 108 > perl -MUnix::Processors -le'print join"\t",$_->id,$_->state,$_->type,$_->clock for @{Unix::Processors->new()->processors}' 0 online HP PA-RISC 2.0 750 1 online HP PA-RISC 2.0 750 a5:/wrk 109 >
d3:/wrk 105 > model 9000/800/D390 d3:/wrk 105 > grep -i d390 /opt/langtools/lib/sched.models D390 2.0 PA8200 d3:/wrk 106 > grep -i d390 /usr/sam/lib/mo/sched.models D390 2.0 PA8000 d3:/wrk 107 > echo "selclass qualifier cpu;info;wait;infolog" | /usr/sbin/cstm | grep "CPU Module" PA 8200 CPU Module 5.1 d3:/wrk 108 >
Or with Perl:
a5:/wrk 108 > perl -MUnix::Processors -le'print join"\t",$_->id,$_->state,$_->type,$_->clock for @{Unix::Processors->new()->processors}' 0 online HP PA-RISC 2.0 750 1 online HP PA-RISC 2.0 750 a5:/wrk 109 >
Some give getconf MACHINE_TYPE
as answer, but it won't work
on HP-UX 10.20. model
will.
The sched.models on the sam path is usually more up to date than the one in langtools
d3:/ 103 # echo itick_per_usec/D | adb -k /stand/vmunix /dev/mem itick_per_usec: itick_per_usec: 240 d3:/ 104 #
Or with Perl:
a5:/wrk 108 > perl -MUnix::Processors -le'print join"\t",$_->id,$_->state,$_->type,$_->clock for @{Unix::Processors->new()->processors}' 0 online HP PA-RISC 2.0 750 1 online HP PA-RISC 2.0 750 a5:/wrk 109 >
r9:/ 112 # echo "selclass qualifier memory;info;wait;infolog" | cstm | grep 'Total Configured' Total Configured Memory : 2048 MB r9:/ 113 # echo 'memory_installed_in_machine/D' | adb -k /stand/vmunix /dev/mem | perl -nle'/(\d+)/&&print$1*4,"k"' 2097152k r9:/ 114 # grep Physical /var/adm/syslog/syslog.log Feb 22 13:40:49 r9 vmunix: Physical: 2095104 Kbytes, lockable: 1557348 Kbytes, available: 1795828 Kbytes r9:/ 115 # echo "selclass qualifier memory;info;wait;infolog" | cstm |\ perl -ne'/^Memory Board Inventory/i../Total.*:/ and print' Memory Board Inventory DIMM Slot Size (MB) --------- --------- 0A 256 0B 256 1A 256 1B 256 2A 256 2B 256 3A 256 3B 256 4A 0 4B 0 5A 0 5B 0 --------- --------- System Total (MB): 2048 r9:/ 116 #
d3:/ 102 > echo 'Yesterday' Yesterday d3:/ 103 > perl -le 'print scalar localtime time - 86400'
Or use A.Clay Stephenson's date hammer, which can also be used for more complicated actions from the command line, as will using the modules Date::Calc or Date::Manip with Perl.
It can be an Oracle CD-ROM, or a CD created on Windows, or whereever they used Rock Ridge extensions. Long names are truncated or show upper case only. Oracle tells you to use pfs_mount.
Do not use pfs_mount!. Install the Rock-Ridge extension patches instead and never worry about these problems. For HP-UX 11.00 you will need forget all about PFS and install PHKL_26448 (now superceded by PHKL_28060), PHCO_26449, and PHKL_26450 to have HP-UX recognize those file systems automatically on mount! For HP-UX 11.11 (11i) you need PHCO_25841, PHKL_26269, and PHKL_25760 (now superceded by PHKL_32035).
No need thereafter to use -o cdfs
to mount
anymore, provided you enter the CD drive in /etc/fstab like this:
/dev/cd0 /cdrom cdfs ro,rr,noauto 0 0
HP-UX 11.2x (Itanium) has a single command to show all:
spe173:/house/procura 4 > /usr/contrib/bin/machinfo CPU info: Number of CPUs = 2 Clock speed = 1500 MHz CPUID registers vendor information = "GenuineIntel" processor serial number = 0x0000000000000000 processor version info = 0x000000001f010504 architecture revision: 0 processor family: 31 Intel(R) Itanium 2 Family Processors processor model: 1 Intel(R) Itanium 2 processor processor revision: 5 stepping B1 largest CPUID reg: 4 processor capabilities = 0x0000000000000001 implements long branch: 1 Bus features implemented = 0xbdf0000060000000 selected = 0x0000000040000000 Bus Lock Signal masked Cache info: L1 Instruction: size = 16 KB, associativity = 4 L1 Data: size = 16 KB, associativity = 4 L2 Unified: size = 256 KB, associativity = 8 L3 Unified: size = 6144 KB, associativity = 24 Memory = 4084 MB (3.988281 GB) Firmware info: Firmware revision = 02.21 FP SWA driver revision: 1.18 IPMI is supported on this system. ERROR: Unable to obtain manageability firmware revision info. Platform info: model string = "ia64 hp server rx2600" machine id number = 7ea3cef8-4491-11d8-8973-de7adaca906d machine serial number = US35074826 OS info: sysname = HP-UX nodename = spe173 release = B.11.23 version = U (unlimited-user license) machine = ia64 idnumber = 2124664568 vmunix _release_version: @(#) $Revision: vmunix: B11.23_LR FLAVOR=perf Fri Aug 29 22:35:38 PDT 2003 $ spe173:/house/procura 5 > model ia64 hp server rx2600 spe173:/house/procura 6 >
© H.Merijn Brand [ 13 Apr 2015 ] |